If you are encountering login problems please check here

Distributor options
#21

All possible, remember, I was out of the game for a decade, so my input must be filtered through the lens of 10 years of change, and memory failure. That being said, if one were going to buy a TFI anyways, I would get the LMR one still. I will be buying one for an 88 that l am resurrecting, so maybe l'll have more to share if it melts in 3 months.
1987 TC - Goldie - Gone but not forgotten
1988 TC - Blue/Blue 5MT Check-off car, trying to save...
Sold the Coupe (hated it), Crushed the 85.5 (rust).
Reply
#22

I have chased weird TFI Ignition issues for some time now, and generally agree with the advice this forum. for reference, I currently have a new production Motorcraft TFI installed (with the part number embossed in the cover).

I have learned that because the age of my car, and the fact that the engine, trans, and wiring have passed through 3 cars, the ignition module is generally not at fault, but is usually with the wiring between the module and the EEC.

1) the aluminum foil shielding breaks down with heat/age, and can be disrupted by the spark plug wire voltage, usually more apparent in distributor mounted modules.  this happened to me twice with store bought aluminum foil, until i broke down and did the repair with copper tape

2)the ignition ground that actually fires the coil may be poor- enough to fire the coil, but the transistor(s) in the module cant handle the increased [resistance?] and will eventually overheat.  I observed this once i remote mounted the TFI, idling in the driveway i would see periods where the oversized heatsink was unreasonably hot to the touch, leading to PIP dropping out (observed on a scope). letting cool and poking at the wiring harnesses would "fix" the problem (no more hot heat sink, no more PIP loss). Ignition ground passes through the EEC, so it makes sense to clean and inspect the computer grounds, and EEC connector in the car as well.  I will note that i was not able to reliably recreate this fault, but have since not encountered it in my drive. alternatively, you may be able to add a dedicated ground in parallel if you suspect this problem and see if that makes an improvement. 

PS, if you are doing any sort of harness repairs, avoid using adhesive backed electrical tape, use the self clinging type, if you have to go back and redo any work, it is a much cleaner alternative.
Ryan
1969 Mach I Mustang
1985 GT T-Top:
LA3, T3, Walbro 255, Stinger FMIC, RR Cam w/Esslinger adj. sproket
Reply




Users browsing this thread: 1 Guest(s)